BUG: Access 2000 Quit Method Leaves Access Running (246953)
The information in this article applies to:
This article was previously published under Q246953 SYMPTOMS
When automating Microsoft Access 2000 and issuing the Quit method, Access does not shut down. You do not receive any error messages but Access remains in the task list.
CAUSE
Microsoft Access 2000 is configured to run under the context of a user that is different from the currently logged in user.
RESOLUTION
The Quit method for Access 2000 only shuts down Access when it is running under the context of the same user that is currently logged into the system (the Interactive User).
To resolve this problem, obtain the latest service pack for Microsoft Office 2000. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
276367 OFF2000: How to Obtain the Latest Office 2000 Service Pack
To temporarily work around this problem, change the user identity that Access 2000 is set to. To do so, follow these steps:
- Click the Windows Start button and then click Run.
- In the Run dialog box, type Dcomcnfg.exe and click OK. This launches the DCOM Configuration Utility.
- In the list of applications, double-click Microsoft Access Application. This brings up the Properties dialog box for Access 2000.
- Click the Identity tab and select The Interactive User. This sets Access to run under the context of the user that is currently logged into the system.
- Click OK to close the Property sheet and click OK again to close the DCOM Configuration Utility.
STATUSMicrosoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Office 2000 Service Pack 2.
Modification Type: | Minor | Last Reviewed: | 9/23/2005 |
---|
Keywords: | kbHotfixServer kbQFE kbAutomation kbbug kbfix kbOffice2000preSP2Fix kbOffice2000sp2fix KB246953 |
---|
|