MOD2000: "Userlist.Connect Unable to Create an Instance" Error After Changing Domains (243979)



The information in this article applies to:

  • Microsoft Office 2000 Developer

This article was previously published under Q243979
Moderate: Requires basic macro, coding, and interoperability skills.

This article applies only to a Microsoft Access project (.adp).

SYMPTOMS

As part of installing the Access Workflow Designer server components to a Microsoft Windows NT 4.0 computer, you do the required install of the Microsoft Windows NT 4.0 Option Pack. Later, after deploying the Issue Tracking solution, you receive the following error message when you attempt to synchronize the user list:
Userlist.Connect unable to create an instance
Access denied

CAUSE

After installing the Microsoft Windows NT 4.0 Option Pack, you changed domains for the server and then installed the Access Workflow Designer server components. The Microsoft Windows NT Option Pack hard codes the IIS Identity settings for the IUSR_MACHINENAME and IWAM_MACHINENAME accounts. So, even after your computer is moved to a different domain, these accounts still point to the "old" domain.

RESOLUTION

To resolve this problem, do either of the following:

  • Move the computer to the "new" domain and then run the Microsoft Windows NT Option Pack.

    -or-

  • Manually update the DCOM permissions.

To manually update the DCOM permissions, do the following:
  1. Start the Distributed DCOM Configuration Properties program. On the Start menu, click Run and type the following:

    dcomcnfg

    Click OK.
  2. If you are prompted twice to record the Msohelp.exe file, click Yes both times.
  3. In the Applications list, scroll down and click the UserList.Connect entry.
  4. Click the Properties button.
  5. Click the Security tab.
  6. Select the Use custom access permissions item. Click the Edit button.
  7. Double-click the user account that either deployed the template or previously installed the Microsoft Windows NT 4.0 Option Pack.
  8. Click OK twice.
  9. Shut down and restart the server computer.

MORE INFORMATION

Steps to Reproduce Behavior

  1. Install Microsoft Windows NT 4.0 Server, Microsoft Windows NT 4.0 SP4, and the Microsoft Windows NT 4.0 Option Pack.
  2. Switch to a different domain.
  3. Install Microsoft SQL Server 7.0, Microsoft Office 2000 Premium (including Microsoft Office Server Extensions and Microsoft FrontPage Server Extensions), and Microsoft SQL Server SP1.
  4. Install the Access Workflow Designer server components.
  5. Deploy the Issue Tracking solution from the Team Solutions Manager.
  6. After the Issue Tracking solution has been deployed, click the User Information tab in the Team Solutions Manager.
  7. Click the Synchronize Now button. You get the error message mentioned earlier in this article.

Modification Type:MajorLast Reviewed:7/31/2001
Keywords:kbprb kbWorkFlowDesigner KB243979