Multiple-Processor Server Hangs When Receiving a Connection Request from a RAS Client (242594)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server, Enterprise Edition 4.0

This article was previously published under Q242594

SYMPTOMS

A multiple-processor server may stop responding (hang) when it receives a connection request from a Remote Access Services (RAS) client. This behavior may occur with Microsoft Windows 95 Dial-Up Networking (DUN) 1.3 and Windows NT 4.0 Workstation clients.

CAUSE

This behavior occurs because the Routing and Remote Access Services (RRAS) server locks and is unresponsive after a period of time. The Microsoft Virtual Private Networking Adapter (NDISWAN) requests a spin lock, but the lock is already held.

RESOLUTION

Windows NT Server or Workstation 4.0

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or the individual software update. For information on obtaining the latest service pack, please go to:
For information on obtaining the individual software update, contact Microsoft Product Support Services. For a complete list of Microsoft Product Support Services phone numbers and information on support costs, please go to the following address on the World Wide Web:

Windows NT Server 4.0, Terminal Server Edition

To resolve this problem, obtain the latest service pack for Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

152734 How to Obtain the Latest Windows NT 4.0 Service Pack


STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT Server version 4.0, Terminal Server Edition Service Pack 6.

Modification Type:MajorLast Reviewed:11/20/2002
Keywords:kbbug kbQFE KB242594