Error Message: "Error 800401e4" Occurs in Trey Manager When Viewing Customer with 0x7c Character in Username (242351)



The information in this article applies to:

  • Microsoft Site Server 3.0 Commerce Edition

This article was previously published under Q242351

SYMPTOMS

In the Trey Research Site Manager, viewing the articles purchased by a user who has the 0x7c character in the Username field causes the following error message to be displayed:
Error '800401e4'
Invalid
/tr/manager/subs_shopper.asp, line 70.

NOTE: The character string ,ou was also added to the user name.

CAUSE

The code in shopper_view.asp uses the vbTextCompare option of the Instr() function, which is case insensitive. It should instead use the vbBinaryCompare option, which is case sensitive.

RESOLUTION

In comtr\manager\shopper_view.asp, change the following line of code:
last = Instr(first+3, shopperDn, ",", vbTextCompare)
				
to this:
last = Instr(first+3, shopperDn, ",", vbBinaryCompare)
				

MORE INFORMATION

Steps to Reproduce Behavior

  1. Open the Trey Research sample site (http://ServerName:5293/tr/).
  2. Register as a new user, and type a double-byte character set (DBCS) Username that contains the 0x7c character.
  3. Purchase an article.
  4. Open the Trey Research Site Manager (http://ServerName:5293/tr/manager/).
  5. Log on using trAdmin as the Member ID, and Password as the password.
  6. Click the Articles button, then click Articles by shopper link.
  7. Select the user you just registered.

Modification Type:MajorLast Reviewed:6/29/2004
Keywords:kbprb KB242351