XCLN: Messages Received from Internet Display SMTP Address on the To and Cc Lines (242301)



The information in this article applies to:

  • Microsoft Outlook 2000
  • Microsoft Outlook Web Access 5.5

This article was previously published under Q242301
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When a user receives a message from the Internet, the user's SMTP address appears on the To or the Cc line instead of their display name.

CAUSE

By default, if the recipient's mailbox is on the same server as the Internet Mail Service, the To, Cc, or Bcc fields, which are all P2 properties, are not resolved against the global address list.

RESOLUTION

In order to force the resolution of all P2 properties against the global address list, you need to turn on the ResolveP2 registry value.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

  1. Start Registry Editor (Regedt32.exe).
  2. Locate the ResolveP2 value under the following key in the registry:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIMC\Parameters

  3. On the Edit menu, click DWORD, type 1, and then click OK.
  4. Quit Registry Editor.
You now need to stop and restart the Internet Mail Service.
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Services.
  3. Locate the Microsoft Exchange Internet Mail Service.
  4. Click the Stop button.
  5. When the Internet Mail Service has stopped, click Start.

MORE INFORMATION

For additional information on the ResolveP2 registry setting, click the article numbers below to view the articles in the Microsoft Knowledge Base:

174755 XFOR: ResolveP2 Registry Setting Expanded in Exchange 5.5

192583 XADM: IMS/STORE Incorrectly Archives Message If ResolveP2 Is On

185153 XFOR: Using Exchange As a Gateway Between UNIX and MS Mail


Modification Type:MinorLast Reviewed:4/28/2005
Keywords:kbprb KB242301