The RPC Server is Unavailable When You Attempt to Add a Printer (242079)
The information in this article applies to:
- Microsoft Windows NT Server 4.0
This article was previously published under Q242079 SYMPTOMS
When you attempt to add a printer to your Microsoft Windows NT-based computer, you may receive the following error message:
Operation could not be completed. The RPC server is unavailable.
CAUSE
This issue can occur if the Spoolss.exe and Spoolss.dll files are missing from the %SystemRoot%\System32 folder, or are damaged.
RESOLUTION
To resolve this issue:
- Copy the Spoolss.exe and Spoolss.dll files from another Windows NT
4.0-based server or workstation to the %SystemRoot%\System32
folder on the affected computer.
- Apply or reapply the latest appropriate Windows NT service pack,
and then restart the computer.
- Set the Remote Procedure Call (RPC) Service to start
automatically:
- Click Start, point to Settings, click Control
Panel, and then double-click Services.
- On the Service list, click Remote Procedure Call (RPC)
Service, and then click Startup.
- Under Startup Type, click Automatic, and then click
OK.
- Restart your computer.
Modification Type: | Major | Last Reviewed: | 8/27/2002 |
---|
Keywords: | kbprb KB242079 |
---|
|