XIMS: MTA Queues Mail for "Inbound Only" Internet Mail Service (238719)



The information in this article applies to:

  • Microsoft Exchange Server 5.0
  • Microsoft Exchange Server 5.5

This article was previously published under Q238719

SYMPTOMS

When the transfer mode on the Connections tab of the Internet Mail Service Properties page is configured as "Inbound Only," the message transfer agent (MTA) may still queue outbound mail for that Internet Mail Service even though the Internet Mail Service does not pick up and deliver the mail.

CAUSE

The Internet Mail Service has an SMTP address space defined on the Address Space tab of the Internet Mail Service Properties page. This address space causes an SMTP route for this Internet Mail Service to appear in the routing table. The MTA sees that as a valid route for outbound SMTP mail. As a result, the MTA queues mail for that Internet Mail Service.

RESOLUTION

This problem can be resolved by removing the Address Space from the Internet Mail Service entirely. To do so, on the Internet Mail Service Properties page, click the Address Space tab, and remove any address spaces that are defined there.

After routing has been recalculated, the SMTP route for that Internet Mail Service should disappear from the routing table. After this occurs, the MTA will no longer queue outbound mail for that Internet Mail Service because it will not see a route for it.

Modification Type:MinorLast Reviewed:4/28/2005
Keywords:kbprb KB238719