Cannot Browse the Internet Using Internet Explorer While Connected to AOL (238550)
The information in this article applies to:
- Microsoft Internet Explorer 5.0 for Windows 98
- Microsoft Internet Explorer 4.01 for Windows 98 SP 2
- Microsoft Internet Explorer 5.0 for Windows 95
- Microsoft Internet Explorer 4.01 for Windows 95 SP 1
- Microsoft Internet Explorer 4.01 for Windows 95 SP 2
- Microsoft Internet Explorer 4.0 for Windows 95
- the operating system: Microsoft Windows 98
- the operating system: Microsoft Windows 98 Second Edition
- the operating system: Microsoft Windows Millennium Edition
This article was previously published under Q238550 NOTE: You may be prompted for your Windows 95, Windows 98, Windows 98 Second Edition or Windows Millennium (Me) CD-ROM to complete the steps listed in article. Verify your installation media before you proceed. IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
When you upgrade Microsoft Internet Explorer or America Online (AOL) and connect to AOL, you may not be able to browse the Internet by using Internet Explorer or you may receive the following error message:
This page cannot be displayed.
Note that you may receive this error message when you use the version of Internet Explorer that is included with the AOL software.
CAUSE
This behavior can occur under the following circumstances:
- If you do not update the Winsock2 registry key and the Transmission Control Protocol/Internet Protocol (TCP/IP) stack after the upgrade procedure
-or- - If you enable the AOL parental control restrictions for the current account
-or- - If you are using a 16-bit version of AOL
RESOLUTIONWARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk.
To resolve this behavior:
- Verify that you are running a 32-bit version of AOL by clicking About America Online on the Help menu.
- Verify that the AOL parental-control restrictions are disabled for the current account.
- Document all the settings in Network properties for your LAN as well
as for your Dial-Up Networking (DUN) connections.
- Remove all network components (for example, adapters, clients, and so on). To do this:
- Click Start, point to Settings, click Control Panel, and then double-click Network.
- Select a network component, and then click Remove.
NOTE: Do not restart your computer if you are prompted to do so.
You may need to repeat these steps to remove all of the adapters, clients, and so on.
- Remove Dial-Up Networking. To do this:
- Click Start, point to Settings, click Control Panel, and then double-click Add/Remove Programs.
- On the Windows Setup tab, click to clear the Communications check box.
NOTE: Do not restart your computer if you are prompted to do so.
- Use Registry Editor to locate and remove the following registry key, and then restart your computer:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\WinSock2
- Start AOL.
- After you start AOL, the necessary AOL components are rebuilt. After the components are rebuilt, restart your computer.
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.
Modification Type: | Minor | Last Reviewed: | 9/27/2004 |
---|
Keywords: | kb3rdparty kbenv kbprb KB238550 |
---|
|