OL2000: Duplicate of Outlook Message Appears on Taskbar (237932)



The information in this article applies to:

  • Microsoft Outlook 2000

This article was previously published under Q237932
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When accessing the body of a message using the Outlook object model from within the OnSubmit event of an extension dll, an orphaned window is created and left on the taskbar. This only occurs running Outlook on Microsoft Windows NT, version 4.0. The window can be maximized and appears to be a valid duplicate message, however it does not function correctly.

CAUSE

This is an operating system issue causing a problem with the way Outlook uses its internal cache.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:

   Date      Time    Version      Size      File name     
   --------------------------------------------------
   07/02/99  04:02p  09.00.00.3024  5,275,698 Outllib.dll 

					


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To enable this fix, modify the following registry entry:
  1. Quit Outlook.
  2. Apply the fixed files noted above.
  3. Start the Registry Editor (Regedt32.exe).
  4. Go to the following key in the registry:

    HKEY_LOCAL_MACHINE\software\microsoft\office\9.0\outlook

  5. On the Edit menu, click Add Value.
       Value Name: DontCacheInspectors
       Data Type: REG_DWORD
       Value: 0x0, 0x1
       Default: 0x0 (not in registry by default)
    					
    Description: This parameter controls the caching used by Outlook.

  6. Click OK, and quit the Registry Editor.
  7. Start Outlook.

Modification Type:MinorLast Reviewed:10/18/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB237932