Custom Import Fails When Importing a Large Membership Database (237788)



The information in this article applies to:

  • Microsoft Site Server 3.0

This article was previously published under Q237788

SYMPTOMS

When you import data from a Site Server 3.0 Personalization and Membership (P&M) database, Custom Import stops abruptly. There are no errors or event log messages.

CAUSE

This occurs because an array length is hard coded to a maximum value and the value is reached during a large import.

RESOLUTION

To resolve this problem, obtain the latest service pack for Site Server 3.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

219292 How to Obtain the Latest Site Server 3.0 Service Pack


STATUS

This problem was first corrected in Site Server 3.0 Service Pack 3.

MORE INFORMATION

To install this fix, run Update.exe. Update.exe will install the correct file for the version of Custom Import (SQL Server or Microsoft Access) and rename it to Cimport.exe.

The LDAP server can limit the number of results returned to the import module even after this fix is applied Ensure that Max Query Results on the LDAP server is set to a sufficient number. The default is 500.

Modification Type:MinorLast Reviewed:9/22/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB237788