SBS Wizards Unable to Connect to Exchange Server (237367)



The information in this article applies to:

  • Microsoft BackOffice Server 4.5
  • Microsoft BackOffice Small Business Server 4.0
  • Microsoft BackOffice Small Business Server 4.0a
  • Microsoft BackOffice Small Business Server 4.5

This article was previously published under Q237367

SYMPTOMS

The Backoffice Server Add User Wizard may not display the dialog boxes for entering the user's Exchange mailbox information and may not be able to create an Exchange mailbox. In addition, the Distribution List Wizard may be unable to create or modify distribution lists and may crash displaying the following error message:
The specified Exchange server could not be found or is not running. This program cannot continue.
Backoffice Server 4.5 may display the following error message:
The taskpad is unable to list items for LDAP://Servername:389/o=Organization Name
Check if LDAP://Servername:389/o=Organization Name is spelled correctly, the resource is available on the network and you are logged on as a user with permission to manage the resource.
Error: 0x80072021

CAUSE

The behavior occurs because the Exchange Server Organization Name contains non-alphanumeric characters. The wizards may not work on Small Business Server or BackOffice Server if the Exchange Server Organization Name contains an ampersand (&), a comma, or a period.

RESOLUTION

To resolve this problem, Microsoft Exchange Server must be removed and reinstalled with an alphanumeric Organization Name. For additional information, please click the article number below to view the article in the Microsoft Knowledge Base:

158028 XADM: Changing the Exchange Organization Name

MORE INFORMATION

When Small Business Server automatically installs Exchange Server, it uses the domain name of the server as the Organization Name, and it uses the server's NetBIOS name as the site name. The only way that the Organization and Site names could be different is if Exchange Server was manually installed. For additional information about Exchange in SBS, please click the article number below to view the article in the Microsoft Knowledge Base:

194810 How to Remove/Reinstall Exchange in SBS


Modification Type:MajorLast Reviewed:12/3/2003
Keywords:kbprb KB237367