Printer Sessions Status Not Updated in SNA Manager (236953)



The information in this article applies to:

  • Microsoft SNA Server 3.0
  • Microsoft SNA Server 3.0 SP1
  • Microsoft SNA Server 3.0 SP2
  • Microsoft SNA Server 3.0 SP3
  • Microsoft SNA Server 4.0
  • Microsoft SNA Server 4.0 SP1
  • Microsoft SNA Server 4.0 SP2

This article was previously published under Q236953

SYMPTOMS

When the SNA Manage Agent Service starts after the SNA Print Service, then some printer sessions status may not be updated correctly in SNA Manager. This generally happens on heavy loaded computers running Windows NT Server that have a lot of services to start.

CAUSE

Because of the high number of services that the Windows NT Server needs to start, it may happen that the SNA Manage Agent Service is started after the SNA Print Service. In such a case, some of the SNA Print Server threads to update status information with SNA Manage Agent may not be initialized correctly.

RESOLUTION

To resolve this problem, obtain the latest service pack for SNA Server version 4.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

215838 How to Obtain the Latest SNA Server Version 4.0 Service Pack


STATUS

Microsoft has confirmed that this is a problem in Microsoft SNA Server version 3.0, 3.0 SP1, 3.0 SP2, 3.0 SP3, 4.0, 4.0 SP1, and 4.0 SP2. This problem was first corrected in SNA Server version 4.0 Service Pack 3.

Modification Type:MinorLast Reviewed:9/22/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE kbsna400sp3fix KB236953