SBS Server Status Tool Reports Web Proxy and Winsock Proxy Error Messages (236179)
The information in this article applies to:
- Microsoft BackOffice Small Business Server 4.5
This article was previously published under Q236179 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
After you configure the Small Business Server (SBS) Server Status tool to send e-mail reports regarding various programs (for example, Web Proxy, Winsock Proxy, Internet Information Server, and so on), you may receive an e-mail message similar to the following examples:
- Web Proxy Logs
The Web Proxy log cannot be sent because Web Proxy is not correctly installed. - Winsock Proxy Logs
The Winsock Proxy log cannot be sent because Winsock Proxy is not correctly installed.
CAUSE
This behavior occurs when the Server Status tool cannot determine the path to the Web Proxy or Winsock Proxy log files. This behavior may occur if you change the path or other options of the Web Proxy or Winsock Proxy logging properties.
RESOLUTIONWARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk.
To resolve this issue:
- Click Start, click Run, type regedt32, and then click OK.
- On the Window menu, click HKEY_LOCAL_MACHINE on Local Machine.
- Locate the following registry key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\W3Proxy\Parameters
- On the Registry menu, click Save Key, type a valid file name when you are prompted to do so, and then click Save.
- Click the LogFileDirectory key, and then click Delete.
- Click the following registry key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\W3Proxy\Parameters
- On the Edit menu, click Add Value.
- Type LogFileDirectory for the Value name.
- Click REG_SZ for the Data Type, and then click OK.
- Type the appropriate path where you want your log files to be stored (for example, C:\Winnt.sbs\System32\Msplogs), and then click OK.
- On the Registry menu, click Close.
To change the Winsock Proxy log path, follow steps 3-9 using the following registry entry:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\WSPSrv\Parameters
To change the Socks Proxy log path, follow steps 3-9 using the following registry entry:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\W3Proxy\Parameters\SOCKS
Modification Type: | Major | Last Reviewed: | 6/11/2002 |
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Keywords: | kbprb KB236179 |
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