POST from Within Microsoft Excel/Microsoft Word Macro Does Not Work Reliably (236020)



The information in this article applies to:

  • Microsoft Internet Explorer 5.0 for Windows NT 4.0
  • Microsoft Internet Explorer 4.01 for Windows NT 4.0 SP 1
  • Microsoft Internet Explorer 4.01 for Windows NT 4.0 SP 2
  • Microsoft Internet Explorer 5.0 for Windows 95
  • Microsoft Internet Explorer 4.01 for Windows 95 SP 1
  • Microsoft Internet Explorer 4.01 for Windows 95 SP 2

This article was previously published under Q236020

SYMPTOMS

When you attempt to POST from within Microsoft Excel or Microsoft Word using a macro, POST requests that should appear in a new browser window may not work.

CAUSE

If the "Check for newer versions of stored pages" cache setting is set to "At every visit to the page" in Internet Explorer, Wininet.dll causes an entry to expire too early. Wininet.dll may also occasionally cause the entry to expire if the "Every time you start Internet Explorer" cache setting is enabled.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Internet Explorer service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:

VersionSizeFile namePlatform
4.72.3707.600388,832Wininet.dllx86



New registry settings have been added for this fix.
  • For Internet Explorer 4.01:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings
    REG_DWORD: SessionStartTimeDefaultDeltaSecs

  • For Internet Explorer 5:

    HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\Cache
    REG_DWORD: SessionStartTimeDefaultDeltaSecs

If this value is not set, or is set to 0, Internet Explorer behaves as it does without the fix.

Setting this value to 2 forces the correct thread to win the race condition. Installing this hotfix sets this value to 2.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/6/2005
Keywords:kbHotfixServer kbQFE kbprb kbProgramming KB236020