Single Sign-On Fails if the Windows NT Primary Domain Controller is Unavailable (235929)
The information in this article applies to:
- Microsoft SNA Server 3.0
- Microsoft SNA Server 4.0
This article was previously published under Q235929 SYMPTOMS
An APPC application configured to use SNA Server's Single Sign-On (SSO) Privileged Proxy feature may fail to connect to the host if the primary domain controller (PDC) where the primary Host Account Cache (HAC) is running becomes unavailable. The APPC application will receive an error message indicating an invalid User ID or Password was used when the problem occurs. For example, an ALLOCATE issued by an APPC application may fail with an error code of 080F6051 (AP_SECURITY_NOT_VALID). NOTE: Applications using the standard SSO (not Privileged Proxy) feature may experience a similar problem if the fix described in the following Microsoft Knowledge Base article is not applied:
235381 SNA Server Access Violation While Determining Proxy Privilege
CAUSE
The SNA Server Host Security DLL (Snasii.dll) was originally designed to issue a GetDCName() call to locate a Windows NT Domain Controller so that it can determine what Windows NT groups the User ID specified by the application belongs to so that it can verify if the application's user context is authorized to make the request. The GetDCName() call always returns the name of the Windows NT PDC. The update discussed in article Q235381 includes a change such that the host security DLL calls GetAnyDCName() to do this same function. The GetAnyDCname() call returns the names of backup domain controllers (BDCs) as well as the PDC. The problem is that this call fails if the PDC is not available.
If the PDC is not available, the GetAnyDCName() fails, so the host security DLL is not able to verify if the application's user context is authorized to make the request that was received. The result is the invalid User ID or Password error being returned to the application.
RESOLUTIONTo resolve this problem, obtain the latest service pack for SNA Server version 4.0. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
215838 How to Obtain the Latest SNA Server Version 4.0 Service Pack
WORKAROUND
Make sure the PDC for the Windows NT domain is available.
STATUSMicrosoft has confirmed that this is a problem in Microsoft SNA Server versions 3.0, 3.0 SP1, 3.0 SP2, 3.0 SP3, 3.0 SP4, 4.0, 4.0 SP1, 4.0 SP2. This problem was first corrected in SNA Server version 4.0 Service Pack 3.
Modification Type: | Minor | Last Reviewed: | 9/22/2005 |
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Keywords: | kbHotfixServer kbQFE kbbug kbfix kbQFE kbsna400sp3fix KB235929 |
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