RUI Application Receives Duplicate MSG10 Screen (234843)
The information in this article applies to:
- Microsoft SNA Server 3.0
- Microsoft SNA Server 4.0
This article was previously published under Q234843 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
If an RUI application is configured to open several instances of pooled LUA sessions, SNA Server may receive a duplicate USSMSG10 (that is, VTAM Signon or "banner") or USSMSG7 (VTAM error) screen on the SSCP-LU session under certain timing conditions. This duplicate screen is then passed to the RUI application during normal session cleanup. Receiving the additional SSCP-LU message may cause problems for the application because it was not expecting to receive this information twice. The actual symptoms experienced are application-specific because it depends on how the application is designed.
NOTE: This problem is not limited to RUI applications and may occur with any application that uses LUA or 3270 LU Pools.
CAUSE
While rapidly deactivating and activating a dependent session, the SNA Server may receive the host's USSMSG10 or USSMSG7 screen (intended for the previous user) after SNA Server has sent a NOTIFY(SLU Enabled) message to activate the session for the new user, along with another USSMSG10 screen for the new session activation. Because SNA Server actually receives two SSCP-LU messages from the host, the 3270 or LUA application receives both messages.
At this time, there has only been one reported instance of this problem because under normal circumstances, a host does not send a USSMSG10 or USSMSG7 screen after receiving a NOTIFY(SLU Disabled) during session cleanup.
RESOLUTIONTo resolve this problem, obtain the latest service pack for SNA Server version 4.0. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
215838 How to Obtain the Latest SNA Server Version 4.0 Service Pack
STATUSMicrosoft has confirmed that this is a problem in Microsoft SNA Server versions 3.0, 3.0 SP1, 3.0 SP3, 3.0 SP4, 4.0, 4.0 SP1, 4.0 SP2. This problem was first corrected in SNA Server version 4.0 Service Pack 3.
Modification Type: | Minor | Last Reviewed: | 9/22/2005 |
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Keywords: | kbHotfixServer kbQFE kbbug kbfix kbQFE kbsna400sp3fix KB234843 |
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