XCON: MTA Loses Attachment on FTBP Messages with No Subject (232370)



The information in this article applies to:

  • Microsoft Exchange Server 5.5

This article was previously published under Q232370

SYMPTOMS

If the Exchange Server Message Transfer Agent (MTA) receives a native X.400 message from a foreign MTA that was sent with a File Transfer Body Part (FTBP) and the originator did not add a subject to the message, depending upon whose foreign MTA sent the message, when the message is viewed by a client, the original attachment is lost, and a zero length attachment called Att.dat is present. If the originator did add a subject, the attachment will be viewed correctly.

CAUSE

The MTA did not correctly handle the different ASN.1 encoding used by the foreign MTA.

RESOLUTION

To resolve this problem, obtain the latest service pack for Exchange Server version 5.5. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

191014 XGEN: How to Obtain the Latest Exchange Server 5.5 Service Pack

The English version of this fix should have the following file attributes or later:

Component: MTA

File nameVersion
Emsmta.exe5.5.2600.0
Ems_rid.dll5.5.2600.0
Mtamsg.dll5.5.2600.0
Infoblog.cfgN/A
Infodlog.cfgN/A
Infollog.cfgN/A
Infoplog.cfgN/A
Infotlog.cfgN/A
Info4log.cfgN/A
Dcprods.catN/A
X400om.dll5.5.2600.0
X400omv1.dll5.5.2600.0
Mtacheck.exe5.5.2600.0
Dbserver.schN/A
P2.xv2N/A

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange Server version 5.5. This problem was first corrected in Exchange Server 5.5 Service Pack 3.

Modification Type:MajorLast Reviewed:10/2/2003
Keywords:EXC55SP3Fix kbbug kbfix kbQFE KB232370