Autoproxy URL Not Applied to Dial-Up Connection During Internet Explorer Setup (232031)



The information in this article applies to:

  • Microsoft Internet Explorer 5.0 for Windows NT 4.0
  • Microsoft Internet Explorer 5.0 for Windows 98
  • Microsoft Internet Explorer 5.0 for Windows 95

This article was previously published under Q232031

SYMPTOMS

When you run Internet Explorer 5 Setup from a custom IEAK built installation package designed for server-less signup, you may be unable to connect to the sign up Web site. For example, you may experience this symptom by performing the following steps:
  1. Create Internet Explorer 5 installation package using IEAK 5 using an ISP customization code.
  2. Specify a server-less signup.
  3. Edit the signup files located in the Program Files\ieak\toolkit\isp\serverless\basic folder.
  4. Edit the .ins file to reflect the autoproxy URL to appear in the URL section:

    [URL]AutoConfig=1 AutoConfigJSURL=http://computername/pacfile.pac.
  5. When you run the Wizard and choose to do a serverless installation, you are prompted to specify your signup files. You should point to the ones that you edited.
  6. Finish the wizard, and then install the package.
  7. After Internet Explorer 5 Setup finishes and your computer restarts, it detects whether or not Dial-Up Networking (DUN) is installed and install.
  8. After restarting, it continues the signup process.
  9. At the end of the process, branding is applied by the .ins file.
  10. All branding is applied except for the reference to the autoproxy URL. The autoproxy URL is specified for the LAN settings, but not the dial-up settings.

CAUSE

This problem can occur if AutoConfig URL does not work. When writing settings to the registry, the branding .dll was not recognizing the connection name resulting in connection information being written to the default connection.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Internet Explorer version 5 that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:

DateTimeVersionSizeFile namePlatform
05/04/9904:30pm153,3601905.exe(x86)
05/04/9904:30pm5.00.2717.0400123,360iedkcs32.dll(x86)


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/6/2005
Keywords:kbHotfixServer kbQFE kbprb kbQFE kbsetup kbui KB232031