SMS: "Cannot Open SQL Server" Error Message and Report Does Not Run When You Schedule Reports (231266)
The information in this article applies to:
- Microsoft Systems Management Server 2.0
- Microsoft Systems Management Server 2.0 SP1
This article was previously published under Q231266 SYMPTOMS
Systems Management Server (SMS) 2.0 includes a version of Crystal Reports. You can use this tool to collate information about how SMS is operating in your organization and to prepare administrative information in an easy-to-read report format.
When you try to schedule a report to run on an SMS 2.0 site server that is running on a Microsoft Windows NT Member server, the report may not run, and you may receive the following error message in the report properties:
Cannot open SQL server
CAUSE
This issue can occur if the SMS Service account does not have the "Act as a part of the Operating System" advanced user right on the SMS site
server. Note that this may occur even if the SMS Service account is not being used to run the report.
RESOLUTION
To resolve this issue:
- Start User Manager for domains, click User, click Select Domain, and then enter the local computer name.
- Click Policies, and then click User rights.
- In the User Rights Policy dialog box, click to select the Show Advanced User Rights check box.
- On the right-sice drop down list box, click Act as part of the operating system.
- Click Add, enter the siteserverdomain\smsserviceaccount in the Add Names box, and then click OK.
- Click OK on User Rights Policy dialog box.
- Stop and then restart all of the following Crystal services:
- Info Agent
- Info APS
- Info Sentinel
Modification Type: | Minor | Last Reviewed: | 6/14/2005 |
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Keywords: | kbBug kberrmsg kbprb KB231266 |
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