Error Messages After Uninstalling Internet Explorer 4.01 SP2 (227040)



The information in this article applies to:

  • Microsoft Internet Explorer 4.01 for Windows 98 SP 2

This article was previously published under Q227040

SYMPTOMS

After you uninstall Internet Explorer 4.01 Service Pack 2 (SP2) on a Microsoft Windows 98-based computer, you may receive the following error messages:
Error loading powrprof.dll A device attached to the system is not functioning.
The COMDLG32.DLL file is linked to missing export SHELL32.DLL:645
An error occurred loading "inetcpl.cpl". The file may not have been installed or it has been corrupted.
Unable to call the function "DllInstall" in the file "mshtml.dll" because that function does not exist or is not exported.
An error occurred loading "msaahtml.dll". The file may not have been installed or it has been corrupted.
Unable to call the function "DllInstall" in the file "urlmon.dll" because that function does not exist or is not exported.
Unable to call the function "DllInstall" in the file "C:\WINDOWS\SYSTEM\Shell32.dll" because that function does not exist or is not exported.
Unable to call the function "DllInstall" in the file "webvw.dll" because that function does not exist or is not exported.
Additionally, many Control Panel tools may not work properly, and you may receive the following error message when you attempt to run programs such as Microsoft Notepad or Microsoft Paint:
A device attached to the system is not functioning.

CAUSE

This behavior can occur if you install Internet Explorer 4.01 SP2 over Internet Explorer 3.x on a Microsoft Windows 95-based computer, upgrade to Windows 98, reinstall Internet Explorer SP2, and then uninstall Internet Explorer SP2. Doing this replaces many files with the Internet Explorer 3.x versions, which are incompatible with Windows 98.

RESOLUTION

To resolve this issue, reinstall Windows 98 over your existing installation. This replaces the Internet Explorer 3.x versions of files with the Windows 98 versions.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:9/30/2003
Keywords:kberrmsg kbprb KB227040