"SNABase not started" if SNA Client for Windows NT is installed from SMS Package (221772)
The information in this article applies to:
- Microsoft SNA Server 3.0
- Microsoft SNA Server 4.0
This article was previously published under Q221772 SYMPTOMS
If a package created by the Systems Management Server Installer is used to install the Windows NT Client for SNA Server, an error message, "SNABase not Started," will occur upon attempting to open a session. If a NET STOP SNABASE then a NET START SNABASE is executed, the connection will work correctly. Another indication of the problem is that it is not possible to manipulate other services in Control Panel, Services until the SNABASE service has timed out.
CAUSE
When the Systems Management Server Installer creates the package, it does not capture all of the necessary registry information. Specifically, two values are missing from the following key:
HKLM/System/CurrentControlSet/Services/SnaBase DependOnService: REG_MULTI_SZ: LanmanWorkstation
NtLmSsp
and
DependOnGroup: REG_MULTI_SZ
The DependOnGroup has no associated value
WORKAROUND
If the above entries are manually added to the Systems Management Server package, then the installation will work properly. To avoid the issue, the Windows NT Client for SNA Server 4.0 can be used in a silent install mode.
MORE INFORMATIONMicrosoft has confirmed that this is a problem in Systems Management Server Installer 1.0.11 to 1.0.45.
Modification Type: | Minor | Last Reviewed: | 2/12/2004 |
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Keywords: | kbPackage kbprb KB221772 |
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