PRJ: Error Message When Sending Workgroup Message or File (218975)



The information in this article applies to:

  • Microsoft Project 2000
  • Microsoft Project 98 for Windows

This article was previously published under Q218975
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

In Microsoft Project, when you send a workgroup message or use the Send command, you may receive one of the following error messages.

Message 1

An unexpected e-mail error has occurred.

Check that the recipient's address is correct.

Free up available memory by closing windows, projects, or programs you aren't using.

If you are using the MailSend macro command, check your arguments to be sure that they are correct.

Try sending fewer enclosures in your email message.

Message 2

Microsoft Project was unable to load an electronic mail program.

Reinstall your electronic mail program and then restart your computer.
NOTE: After you receive this message, the workgroup or Send menu item will be disabled.

CAUSE

Cause for Message 1

This error message may occur when you send a Microsoft Project workgroup message and the e-mail profile setting "Deliver new mail to the following location" is set to None.

Cause for Message 2

This error may occur when you send a Microsoft Project workgroup message or use the Send command.

WORKAROUND

Workaround for Message 1

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click the Mail or Mail and Fax icon.
  3. Click the Delivery tab.
  4. In the Deliver new mail to the following location list, click anything other than None.
  5. Click OK.

Workaround for Message 2

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

Delete the key following key in the registry:

HKEY_LOCAL_MACHINE\Software\Microsoft\Office\8.0\Common\MapiDLL

To do this, follow these steps:

NOTE: Close Microsoft Project before performing these steps.
  1. Click Start, and then click Run.
  2. In the Open box, type Regedit and click OK.
  3. Double-click the HKEY_LOCAL_MACHINE folder.
  4. Continue to expand folders until you reach the key:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Office\8.0\Common\MapiDLL

  5. Click to select the MapiDLL folder.
  6. On the Edit menu, click Delete.
  7. Click Yes to delete the key.
  8. On the Registry menu, click Exit.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:10/7/2003
Keywords:kbbug kberrmsg kbpending KB218975