OL2000: (CW) Clicking No at Windows Login Creates a Default Account (218389)



The information in this article applies to:

  • Microsoft Outlook 2000

This article was previously published under Q218389
NOTE: The procedures in this article only apply if you have installed Outlook with the Corporate or Workgroup option. With this option, you can use Messaging Application Programming Interface (MAPI) services. To determine your installation type, click About Microsoft Outlook on the Help menu. If you have the Corporate or Workgroup installation, you see "Corporate or Workgroup".

IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you log on to Outlook for the first time on a shared computer, you are not prompted with a first run condition. Everyone who logs on to this computer sees the same e-mail account.

CAUSE

When prompted with the message

You have not logged onto this machine before. Would you like Windows to retain your personal settings?


someone clicked No. That person's information was written to the default users key in the registry.

RESOLUTION

Remove the default user profile and edit the registry to remove the default user settings. The user will then need to log on to the computer and click Yes to have Microsoft Windows retain their personal settings.

MORE INFORMATION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

When you log on to the computer for the first time, you are prompted with the message in the "Cause" section. If you click No, any settings changes you make, including mail profile settings, are written to the default user's registry key. This information will be included with all users who log on to that computer.

To resolve this, delete the default user settings in the registry, delete that user's profile, and have them log in again. Otherwise, everyone after the person who clicked No will have the same mail profile/account.

To remove the registry key and the profiles:
  1. Quit all open programs.
  2. click Start, and click Run.
  3. Type regedit, and then click OK.
  4. Navigate to the following registry key:

    HKEY_USERS\.Default\Software\Microsoft\Office\9.0\Outlook\Setup

  5. Click to select the Setup folder, and on the Edit menu, click Delete.
  6. Navigate to the following registry key:

    HKEY_USERS\.Default\Software\Microsoft\Windows\Microsoft Windows Messaging\Profiles

  7. Delete the folders under the Profiles folder. These contain profile information.
  8. Quit the registry editor. Each new user must now log on to Windows and click Yes, when prompted to keep their personal settings.

Modification Type:MajorLast Reviewed:9/29/2003
Keywords:kbprb KB218389