Client Automation Issues after You Click Next in OCManager (218002)



The information in this article applies to:

  • Microsoft BackOffice Small Business Server 4.0
  • Microsoft BackOffice Small Business Server 4.5

This article was previously published under Q218002

SYMPTOMS

An administrator can use the Setup Computer Wizard included in Microsoft BackOffice Small Business Server to:
  • Configure the server for clients.
  • Configure networking.
  • Install programs on client computers.
The Setup Computer Wizard creates a configuration disk you can use to configure a client computer. This disk contains the following 5 files:
  • Setup.exe
  • Ipdetect.exe
  • Ipdx86.exe
  • Ipd2000
  • Netparam.ini
The client setup file (Setup.exe) is an installer that invokes either Ipdetect.exe, Ipdx86.exe, or Ipd2000, depending on the client operating system. When you install Windows NT Workstation, client setup also forces Windows NT Service Pack 4 (NTSP4) to run after the network configuration process finishes.

When the installation finishes, client setup creates an Installed file in the Response folder on the server. This denotes a successful program installation and prevents the server from installing programs on subsequent reboots.

Manual intervention may result in failure to execute, update, modify, and/or create the appropriate registry keys, files, folders or other system components. If this occurs, you may experience one or more of the following symptoms:
  • Programs may not install correctly, or they may be installed in an incorrect order.
  • Loss of network connectivity.
  • Windows NT 4.0, Service Pack 4 may not install correctly.
  • The client Setup program may not complete successfully.

CAUSE

This problem can occur if you click Next in OCManager during unattended mode on a Windows NT Workstation-based computer. If you do so, Office programs are not installed in the correct order, and you may lose network connectivity.

RESOLUTION

To work around this problem, do not click Next in OCManager during unattended mode. Instead, wait until the client set up process finishes, all programs are correctly installed, and networking is correctly configured.

STATUS

Microsoft has confirmed this to be a problem in Microsoft BackOffice Small Business Server 4.5.

Modification Type:MajorLast Reviewed:11/21/2003
Keywords:kbbug kbnetwork kbnofix kbsetup KB218002