Unable to restart Registration Wizard (217623)



The information in this article applies to:

  • the operating system: Microsoft Windows 2000
  • the operating system: Microsoft Windows 98
  • the operating system: Microsoft Windows Millennium Edition
  • the operating system: Microsoft Windows 95
  • Microsoft Office 2000 Premium
  • Microsoft Office 2000 Professoinal
  • Microsoft Office 2000 Standard
  • Microsoft Office 2000 Small Business
  • Microsoft Office 2000 Developer
  • Microsoft Access 2000
  • Microsoft Excel 2000
  • Microsoft FrontPage 2000
  • Microsoft Outlook 2000
  • Microsoft PowerPoint 2000
  • Microsoft Word 2000

This article was previously published under Q217623
Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

The first time that you start a Microsoft Office program, you may be prompted to register Microsoft Office. However, you cannot restart the registration process if you do any of the following:
  • You click No when prompted.
  • You click Register Later in the Registration Wizard.
  • You click Yes when prompted, but then you click Cancel to quit the Registration Wizard.
Even if you uninstall Office and then reinstall it, you will not be prompted to register.

NOTE: This article only applies to the voluntary registration process, which uses Regwiz.exe on all operating systems listed at the beginning of this article. The Office Registration Wizard, which uses a different mechanism for the registration process, is included in Office 2000 in Brazil, Australia, New Zealand, the Academic market in the U.S. and Canada, and the full package Office 2000 SR-1 product.

For additional information about the mandatory Office Registration Wizard, click the following article numbers to view the articles in the Microsoft Knowledge Base:

270927 Prompt to register when trying to use SR-1 program

277989 Cannot run programs if ORW is skipped 50 times

For more information about the Office Registration Wizard, please browse to the following Microsoft Web site:

CAUSE

The message prompting you to register your copy of Office is only designed to appear the first time you start any of the Office programs. If you click No when prompted, or if you cancel the registration process, the Office programs are designed to never prompt you again.

WORKAROUND

If you are using Microsoft Windows NT 4.0, your only option is to mail in your registration card. Windows NT 4.0 does not install a copy of Regwiz.exe, which Office uses to perform the registration process.

NOTE: Some versions of Office 2000 do not include a registration card. For more information about registering your product if you are outside the United States, contact the Microsoft subsidiary for your area. To locate your subsidiary, see the Microsoft World Wide Offices Web site at:
To restart the Registration Wizard and register your copy of Office, you have two choices:
  • Mail in the registration card in the box containing your Office software.

    -or-
  • Restart the Registration Wizard by using the command prompt.
To restart the Registration Wizard for Office, follow these steps:
  1. Click Start, and click Run.
  2. In the Open box, type the following command:

    Regwiz.exe /i "software\microsoft\office\9.0\common\LV"

  3. Click OK.

    The Microsoft Office 2000 Registration Wizard appears.
  4. Complete the information in the Registration Wizard.
If you receive an error while restarting the Registration Wizard, please follow these steps:

NOTE: The following steps may produce an invalid page fault in Regwiz.exe on computers running Windows 95. If you receive this error message, please use the mail-in method to register.


Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. On the Start menu, click Run.
  2. In the Open box, type Regedit and then click OK.
  3. In the left pane of Registry Editor, locate and select the following subkey (folder):

    HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Common\LV

  4. On the Edit menu point to New and then click String Value.
  5. With New Value #1 selected in the right-pane, type ProductID and then press ENTER.
  6. On the Edit menu point to New and then click String Value.
  7. With New Value #1 selected in the right-pane, type ProductName and then press ENTER.

    The data values for the ProductID and the ProductName string values will vary according to the version of Office you installed.
  8. In the left pane of Registry Editor, locate and select the following subkey (folder):

    HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Registration\ProductID

  9. In the right pane, double-click the (Default) icon.
  10. Copy the number displayed in the Value data box and click Cancel.
  11. Locate and select the following key in the registry:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Common\LV

  12. In the right-pane, double-click the ProductID icon.
  13. In the Value data box, paste the value you copied in step 10. Click OK.
  14. At the top of the left pane of the Registry Editor, click My Computer.
  15. On the Edit menu, click Find.
  16. In the Find what box, type ProductName and click Find Next.
  17. Repeat step 16 until you locate the ProductName entry that corresponds to your version of Office, for example: "Microsoft Office 2000 Premium".
  18. In the right pane, double-click the ProductName icon for this entry.
  19. Copy the text displayed in the Value data box and click Cancel.
  20. In the left pane of Registry Editor, locate and select the following subkey (folder):

    HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Common\LV

  21. In the right pane, double-click the ProductName icon.
  22. In the Value data box, paste the value you copied in step 19. Click OK.
  23. On the Registry menu, click Exit.
  24. To restart the Registration Wizard, repeat steps 1-4 at the beginning of the "Workaround" section.

Modification Type:MinorLast Reviewed:10/13/2006
Keywords:kbMSCCSearch kbPubTypeKC kbbug kbnofix KB217623