Setup does not run or you receive an "Error opening installation log file" error message when you run Office 2000 Setup (217560)



The information in this article applies to:

  • Microsoft Office 2000 Premium
  • Microsoft Office 2000 Professoinal
  • Microsoft Office 2000 Standard
  • Microsoft Office 2000 Small Business
  • Microsoft Office 2000 Developer
  • Microsoft Access 2000
  • Microsoft Excel 2000
  • Microsoft FrontPage 2000
  • Microsoft Outlook 2000
  • Microsoft PowerPoint 2000
  • Microsoft Word 2000

This article was previously published under Q217560

SYMPTOMS

When you attempt to run Office Setup, you may experience one of the following symptoms:
  • Setup does not run, and no log file is generated. -or-

  • You receive the following error message:
    Error opening installation log file. Verify that the specified log file location exists and is writable.
NOTE: These symptoms do not occur on Microsoft Windows NT.

CAUSE

These symptoms can occur for the following reasons.
  • Setup does not run and no log file is generated:

    This symptom occurs when you run the Setup program in Quiet mode, and you use a system environment variable for the log file location, as shown in the following example:

    \\Server\Share\Setup.exe /qn /l* "%TEMP%\LogFile.txt"
    						

  • The error message "Error opening installation log file" appears:

    This symptom occurs when you run the Setup program (with no Quiet mode switch), and you use a system environment variable for the log file location, as shown in the following example:

    \\Server\Share\Setup.exe /l* "%TEMP%\LogFile.txt"
    						

WORKAROUND

To use an environment variable such as %TEMP% on Microsoft Windows 95 or later, specify these variables in the Setup.ini file, instead of on the command line. The log file location can be specified in the Path statement of the Logging section of the Setup.ini file, as in the following example:

[Logging]
Type=icewarmup
Path=%TEMP%
Template=Office %username%(*).txt

NOTE: Both the Office Setup and Windows Installer programs create their log files in the system Temp folder by default. If you leave the Path= statement in the Setup.ini file, or you do not specify a path when using the /l logging switch, the log file will be created in the system Temp folder.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

When running the Office Setup program, you can create a log file by adding the /l switch on the command line. Unless you specify a log file name and location, Office will create two text log files, one for Setup.exe and one for the Windows Installer, by default. However, on Microsoft Windows 95 or later, if you specifiy the log file location using an environment variable such as %TEMP%, the Setup program ends. If you are running Setup in Quiet mode, an error message does not appear.

For additional information about customizing Office Setup logging options, click the article number below to view the article in the Microsoft Knowledge Base:

230861 OFF2000: How to Customize Office Setup Logging Options

For additional information about Setup switches for Microsoft Office 2000, click the article number below to view the article in the Microsoft Knowledge Base:

202946 Setup Command-Line Switches for Office 2000


Modification Type:MinorLast Reviewed:10/13/2006
Keywords:kbtshoot kbpending kbprb kbsetup KB217560