Catalog corruption occurs after indexing is complete (217151)



The information in this article applies to:

  • Microsoft Index Server 2.0

This article was previously published under Q217151
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

Index Server reports that the catalog is corrupt after the index process is completed. This can occur as soon as the indexing process has completed, or several minutes later.

CAUSE

This behavior occurs if a file is unfilterable and the value of the Filter Retries registry key is set to a number that is less than 4. When this happens, the information that the filter process sends to the Content Index Service (CISVS) causes the CISVS to report that the in-memory catalog information is corrupt, even though the data on the drive is fine.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

Change the value of the following registry key to 4 or greater:

HKEY_LOCAL_MACHINE\system\currentcontrolset\control\contentindex\FilterRetries

After you change this value, restart Index Server.

STATUS

Microsoft has confirmed that this is a problem in Index Server version 2.0.

Modification Type:MajorLast Reviewed:5/30/2004
Keywords:kbbug kbpending KB217151