Unable to Connect Three Levels Higher in a Domain (215422)



The information in this article applies to:

  • Microsoft Windows 98
  • Microsoft Windows 95

This article was previously published under Q215422
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you try to connect your Windows 95-based or Windows 98-based computer to a server that is more than two levels higher in the domain name tree structure than your computer, you may not be able to connect until you provide the fully qualified domain name (FQDN). For example, if your client computer has the following name

mycomputer.subdomain3.subdomain2.subdomain1.example.microsoft.com

the domain suffix is:

subdomain3.subdomain2.subdomain1.example.microsoft.com

If you want to establish a file transfer protocol (FTP) session to a server named myserver.example.microsoft.com, you must type this full name to connect. If you type only myserver, the client queries the domain name server (DNS) for the following names:

  • myserver.subdomain3.subdomain2.subdomain1.example.microsoft.com
  • myserver.subdomain2.subdomain1.example.microsoft.com (one level higher)
  • myserver.subdomain1.example.microsoft.com (two levels higher)

CAUSE

This problem can occur because the domain name resolver (DNR) component in Windows 98 and Windows 95 does not support going higher than two levels of a domain suffix.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.



DateTimeVersionSizeFile namePlatform
01/19/994:58p4.10.200144,032rnr20.dllWindows 98
01/19/996:11p4.10.166143,520rnr20.dllWindows 95 Winsock2

NOTE: Because of file dependencies, the most recent hotfix or feature that contains these files may also contain additional files.

In addition to applying the hotfix, use Registry Editor to add a REG_DWORD value to the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VxD\MSTCP
Value name: MaxDomainsSearchListSize
Data type : REG_DWORD

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

This problem was corrected in Windows 98 Second Edition.

MORE INFORMATION

For additional information about Windows 98 and Windows 98 Second Edition hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:

206071 General Information About Windows 98 and Windows 98 Second Edition Hotfixes

For additional information about Windows 95 hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:

161020 Implementing Windows 95 Updates


Modification Type:MinorLast Reviewed:10/18/2005
Keywords:kbHotfixServer kbQFE kbnetwork kbprb kbQFE kbui KB215422