FP2000: "Socket Code 4" Error Connecting to Server Using SSL (205245)
The information in this article applies to:
This article was previously published under Q205245 For a Microsoft FrontPage 98 version of this article, see 194672.
For a Microsoft FrontPage 97 version of this article, see 161963.
SYMPTOMS
When you attempt to connect to a Web server using Secure Sockets Layer
(SSL), you may receive the following error message:
Unable to connect to a server at "<ServerName>" on port 443 (socket code 4)
where <ServerName> is the name of the server you are connecting to and 443 is the port configured to receive secure connections.
The server log might also show the following error:
Secure handshake failed.
CAUSE
FrontPage currently recognizes the following certificate authorities:
Secure Server Certification Authority (Verisign/RSA)
AT&T Directory Services
AT&T Certificate Services
However, if Internet Explorer 5 is installed on the client computer, FrontPage will recognize all certificates that Internet Explorer 5 recognizes.
RESOLUTIONMethod 1: Configure the Web Server Software with an SSL Certificate
To allow FrontPage to connect to the server via SSL, configure the Web
server software with an SSL certificate from one of the certificate
authorities listed in the "Cause" section of this article.
Method 2: Upgrade to Internet Explorer version 5.0.
Upgrade to Internet Explorer version 5.0.
NOTE: FrontPage supports 40-bit encryption without the use of Internet Explorer version 5.0. If Internet Explorer version 5.0 is installed with 40-bit encryption, then FrontPage will only use 40-bit encryption. If Internet Explorer version 5.0 is installed with 128-bit encryption, then FrontPage can use 128-bit encryption. FrontPage does not support 128-bit encryption.
FrontPage will accept certificates authorities supported by Internet Explorer version 5.0, if Internet Explorer 5 is installed.
Modification Type: | Major | Last Reviewed: | 10/1/2001 |
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Keywords: | kbprb KB205245 |
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