You cannot fnd the Dumpster.ecf file When you open Outlook (204115)
The information in this article applies to:
This article was previously published under Q204115 NOTE: These procedures only apply if you have installed Outlook with the Internet Mail Only option. To determine your installation type, click About Microsoft Outlook on the Help menu. If you have the Internet Mail Only option installed, you see "Internet Mail Only". For information about the differences between Microsoft Outlook and Microsoft Outlook Express e-mail clients, click the following article number to view the article in the Microsoft Knowledge Base: 257824 OL2000: Differences Between Outlook and Outlook Express IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
When you start Outlook in Internet Mail Only (IMO) mode, you may receive the following error message:
The file add-in dumpster.ecf is missing or not valid please locate the file and move it to the Outlook program folder.
CAUSE
This behavior occurs because the Service Release 2 (SR-2) patch updates the Dumpster.ecf file in the %ProgramFiles%\Microsoft Office\Office folder to a version that Outlook cannot use in IMO mode.
RESOLUTION
To resolve this behavior, follow the steps in this section. How to Cancel the Dumpster Add-In Selection in the Add-In Manager
To cancel the Dumpster add-in selection:
- Start Outlook.
- Click Options on the Tools menu.
- On the Other tab, click Advanced Options.
- In the Advanced Options dialog box, click Add-In Manager.
- In the Add-in Manager dialog box, click to clear the Deleted Item Recovery check box.
- Click OK, click OK, and then click OK.
How to Rename the Dumpster.ecf File
If the Delete Item Recovery add-in is not in the Add-ins Manager dialog box, follow these steps to rename the Dumpster.ecf file:
- Click Start, point to Find, and then click Files and Folders.
- In the Named box, type dumpster.ecf, and then click Find Now.
NOTE: Click your entire hard disk, usually your drive C, in the Look In box. - Right-click the file, and then click Rename.
- Change the file name from dumspter.ecf to dumpster.old, and then press ENTER.
- Close the Find All Files box, and then restart Outlook.
How to Refresh the Extend.dat File
If you receive the error message that is described in the "Symptoms" section of this article when you restart Outlook, refresh the Extend.dat file. The Extend.dat file is a binary file that caches the registry extension entries.
To refresh the Extend.dat file:
- Quit all programs.
- Click Start, point to Find, and then click Files and Folders.
- In the Named box, type extend.dat.
- In the Look In box, click your hard disk.
- Click Include subfolders, and then click Find Now.
- In the Name box, right-click the Extend.dat file, and then click Rename, and then rename the file to extend.old.
- On the File menu, click Close.
- Restart Outlook. When you restart Outlook, a new Extend.dat file is created.
How to Remove the Registry EntriesWARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk.
To remove the registry entries:
- Quit all programs.
- Click Start, and then click Run.
- In the Open box, type regedit.exe, and then click OK.
- Locate and click the following registry key:
HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Client\Extensions
The add-ins are listed in the left pane under "Data" (without quotation marks).
- Click the name of the data key from the error message in the "Symptoms" section, and then press DELETE.
- Click Exit on the Registry menu.
- Restart your computer, and then restart Outlook.
Modification Type: | Minor | Last Reviewed: | 10/15/2004 |
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Keywords: | kbprb KB204115 |
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