Computer Stops Responding When You Play Very Large .wav Files (203795)



The information in this article applies to:

  • Microsoft Windows 98
  • Microsoft Windows 95
  • Microsoft Windows Millennium Edition

This article was previously published under Q203795
If this article does not describe your hardware-related issue, please see the following Microsoft Web site to view more articles about hardware:

SYMPTOMS

When you attempt to play a large wave (.wav) file in Microsoft Sound Recorder (Sndrec32.exe), your computer may stop responding (hang).

CAUSE

This issue can occur if the size of the file you are attempting to play is equal to or greater than the amount of Random Access Memory (RAM) installed in your computer. Before playing the file, Sound Recorder tries to load the entire .wav file into memory, but may not be able to do so. For example, if you attempt to play a 32 megabyte (MB) .wav file and your computer has 32 megabytes of RAM or less, your computer may stop responding.

RESOLUTION

To work around this problem use the appropriate method:

Use Microsoft Windows Media Player 7

You can use Windows Media Player 7 to play the file.

Use Microsoft Active Movie to Play the File

Use Active Movie to play the file:
  1. Click Start, point to Programs, point to Accessories, point to Multimedia, and then click Active Movie.
  2. On the File menu, click Open, open the folder that contains your .wav file, click the file, and then click Open.

Install More RAM

You can increase the amount of ram in your computer to enable this tool to play large .wav files.

MORE INFORMATION

Active Movie does not load the entire file into memory before playing it, instead, it buffers it in segments from the hard disk or CD-ROM.

Modification Type:MajorLast Reviewed:7/13/2006
Keywords:kbprb kbsound KB203795