Cannot Connect with Dial-Up Networking When WSP Client Is Enabled (196267)
The information in this article applies to:
- Microsoft Windows 2000 Professional
- Microsoft BackOffice Small Business Server 4.0
- Microsoft BackOffice Small Business Server 4.0a
- Microsoft BackOffice Small Business Server 4.5
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT Workstation 4.0
This article was previously published under Q196267 SYMPTOMS
A dial-Up Networking connection can be made from a Small Business Server
(SBS) client computer to a dial-up IP network.
The SBS client computer gets an IP address from the Dial-Up Server and it
is correct when viewed with Winipcfg.exe.
User cannot browse the Internet or send/receive POP3/SMTP mail.
Pinging the external destinations can fail as well as the NSLOOKUP, FTP,
TELNET commands.
A Network Monitor trace shows traffic being sent to SBS/Proxy Server.
CAUSE
The WinSock Proxy Client is installed and enabled on the SBS client
computer.
RESOLUTION
On SBS client computers, it is normal for the WinSock Proxy Client (WSP
Client tool in the Control Panel) to be installed and enabled by default.
This is to allow for the SBS client computers to use the SBS server as a
proxy to the Internet.
To allow for IP traffic to use a dial-up networking session from an SBS
client computer, the WSP Client must be disabled for the duration of the
dial-up networking session.
To Disable the WSP Client- Click Start, click Settings, and then click Control Panel.
- In Control Panel, double-click WSP Client.
- Click to clear the Enable WinSock Proxy Client check box.
- Click OK.
- Restart your computer when prompted.
NOTE: It is not necessary to restart the client computer after disabling the WSP Client unless there is an active WinSock session.
To re-establish Internet connectivity through the SBS server, follow the
above steps, only enable the WinSock Proxy Client.
All CERN compatible applications like Internet Explorer should be
configured NOT to use Proxy Server.
To do so in Internet Explorer, on the View menu, click Internet Options.
Click the Connections tab, and then click to clear the Access the Internet using
a proxy server check box.
STATUS
This behavior is by design.
MORE INFORMATION
The WSP Client intercepts sockets-based IP traffic and redirects this
traffic to a Proxy server. If active while a dial-up networking session is
created, the WSP Client will redirect most IP traffic that should go
through the dial-up networking connection to go, instead, to the Proxy
server.
Modification Type: | Minor | Last Reviewed: | 12/16/2004 |
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Keywords: | kbprb KB196267 |
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