Error Message: Acmsetup Caused an Invalid Page Fault in Msvcrt.dll (193830)



The information in this article applies to:

  • Microsoft Graphics Studio Greetings 99
  • Microsoft Graphics Studio Home Publishing 99

This article was previously published under Q193830
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you attempt to install one of the programs listed at the beginning of this article, you may receive the following error message:

ACMSETUP This program has performed an illegal operation and will be shut down.

If the problem persists, contact the program vendor.

When you click Details, you receive the following information:

ACMSETUP caused and invalid page fault in module MSVCRT.DLL

CAUSE

This error message occurs if a Windows registry entry for Clip Gallery is incorrect.

Home Publishing 99 and Greetings 99 install Clip Gallery version 5.0. During the installation process, the Setup program checks the Windows registry to determine the location of any Clip Gallery Packages (.cag files) installed by previous versions of Clip Gallery. If Setup finds an entry for a Clip Gallery Package that does not include the location of the .cag file, the Setup program cannot continue, and you receive the error message listed earlier in this article.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.


To resolve this issue, back up your Windows registry, and then locate the invalid registry subkey. To do this, follow these steps:

  1. Make a backup copy of your registry. To do this, follow these steps:

    1. Click Start, and then click Run.
    2. In the Open box, type regedit, and then click OK.
    3. On the Registry menu, click Export Registry File.
    4. In the File Name box, type a name for the file, and then click Save.
    If you need to, you can double-click this file to restore your Windows registry to its original state.
  2. Locate the registry subkey that does not contain the .cag file location. To do this, follow these steps:

    1. In the left pane of Registry Editor, double-click the following registry key:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ClipArt Gallery\2.0\Import
      								
    2. Click each product subkey, and verify that the subkey contains a "CAG" entry in the Name column and a path value in the Data column. The product subkeys may have names like "Works Popular Clipart" or "Office97 Clipart." If there are no subkeys listed, continue to the next step.
    3. Double-click the following registry key:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ClipArt Gallery\3.0\ConcurrentDatabases
      								
    4. Repeat steps B-C, until you find a subkey that does not contain a "CAG" entry. When you find a subkey that does not contain a "CAG" entry with a path value in the Data column you have located the invalid registry entry.
Once you have located the invalid registry entry, you can resolve this issue using the following method.

Delete the Invalid CAG Entry

To delete the invalid CAG entry, follow these steps:

  1. In Registry Editor, click the product subkey containing the invalid CAG entry. For example, if the invalid entry was in the "Microsoft Works Clipart" subkey, you would click the following subkey:

    HKEY_LOCAL_MACHINE\Software\Microsoft\ClipArt Gallery\2.0\Import\Microsoft Works Clipart
    						
  2. On the Edit menu, click Delete. When you are prompted to confirm the deletion, click Yes.
  3. Reinstall Home Publishing 99 or Greetings 99.

MORE INFORMATION

This issue has been encountered primarily with Compaq Presario 56xx computers running Microsoft Windows 98, with Microsoft Works for Windows version 4.5 preinstalled on the computer.

Modification Type:MajorLast Reviewed:11/5/2003
Keywords:kbenv kberrmsg kbFAQ kbprb kbsetup KB193830