How to Resolve Catalog Corruption (191147)
The information in this article applies to:
- Microsoft Index Server 1.0
- Microsoft Index Server 1.1
- Microsoft Index Server 2.0
This article was previously published under Q191147 SYMPTOMS
You may see the error "the catalog is corrupt" when you issue a query in
the browser. You may also see catalog corruption errors in the application
event log. These messages will vary depending on the type of corruption
detected.
CAUSE
Index Server catalog corruption can be caused by unsafe computer shutdowns, system crashes, or applications that write to or lock the catalog files while Index Server is active.
RESOLUTION
Normally, Index Server attempts to fix any corruption automatically;
however, sometimes it is necessary to manually fix the corruption. To do
manually fix corruption, stop and restart the Content Index service (for
Index 1.x, stop and restart the World Wide Web service.) This normally
causes Index Server to rebuild the catalog. If this does not work, stop
Index Server again, locate the Catalog.wci folder, and delete the contents
of the folder. This manually deletes the catalog. When you restart Index
Server, the catalog is re-created.
Note: If the Web Server is using the FrontPage Server Extensions, make sure the catalog is not inside the Web.
Modification Type: | Major | Last Reviewed: | 10/22/2003 |
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Keywords: | kbprb KB191147 |
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