Err Msg: Error CTSOUND1008: Invalid "/BLASTER=A:xxx" Argument (190171)



The information in this article applies to:

  • Microsoft Windows 98

This article was previously published under Q190171
If this article does not describe your hardware-related issue, please see the following Microsoft Web site to view more articles about hardware:

SYMPTOMS

When you upgrade Microsoft Windows 3.x to Windows 98 on a computer with a Creative Labs Sound Blaster 16 sound card installed, you may receive the following error messages when your computer starts:
Driver Unit Number = 0
Error CTSOUND1008: Invalid "/BLASTER=A:xxx" argument

-and/or-

Error: DIGN8002 The BLASTER environment settings are invalid

CAUSE

This behavior can occur if Plug and Play configuration drivers for the Sound Blaster 16 sound card are being loaded from the Autoexec.bat and Config.sys files.

RESOLUTION

To resolve this issue, follow these steps:
  1. Click Start, click Run, type Sysedit in the Open box, and then click OK.
  2. On the Windows menu, click Autoexec.bat, locate the line that loads the Sound Blaster driver, and then type rem followed by a space at the beginning of the line. For example, the line in your Autoexec.bat file may be similar to the following line:
          c:\vibra16\diagnose /s /w=c:\windows
     
    						
  3. On the Windows menu, click Config.sys, locate the line that loads the Sound Blaster driver, type rem, followed by a space at the beginning of the line. For example, the line in your Config.sys file may be similar to the following line:
          device=c:\vibra16\drv\vibra16.sys /unit=0 /blaster=a:220 i:10 d:3 h:7
     
    						
  4. On the File menu, click Exit.
  5. Click Yes when you are prompted to save the Config.sys and Autoexec.bat files.
  6. Restart your computer.

STATUS

Microsoft has confirmed that this behavior is not caused by a problem in Windows 98, but may be caused by design changes in Windows 98. For more information about resolving this issue, contact the program's manufacturer.

Modification Type:MajorLast Reviewed:8/8/2006
Keywords:kberrmsg kbHardware kbprb KB190171