Setup Error 80020009 or Error 800401E4 (189747)



The information in this article applies to:

  • Microsoft Site Server 3.0

This article was previously published under Q189747

SYMPTOMS

During the installation of Site Server 3.0, you may receive the following error messages:
Failed to get File System Object -- Error Number=80020009 (-2147352567) String=No matching entry.
Failed to connect to LDAP server -- Error Number=800401E4 (-2147221020) String=

CAUSE

This issue may be caused by one of the following:

The default Web site does not have Windows NT Challenge/Response authentication enabled. As a result, installation of the Site Server Publishing examples fails.

-OR-

The local Everyone NT group does not have the advanced User Right "Access this computer from network."

Note: If you have the Compaq Insight Manager Service running while attempting to install Site Server 3.0, the following error message may also occur:
Failed to connect to LDAP server -- Error Number=800401E4 (-2147221020) String=

WORKAROUND

To work around this problem, follow the appropriate steps:

Enabling NTCR on Default Website
  1. Uninstall Site Server 3.0.
  2. Enable Windows NT Challenge/Response authentication for the default Web site. To do so, follow these steps:

    1. Select the default Web site in Microsoft Management Console (MMC).
    2. Right-click to select Property, and then select Directory Security.
    3. Select Anonymous Access and Authentication Control.
    4. Select Windows NT Challenge/Response.
  3. Install Site Server 3.0.
Granting "Access this computer from network" User Right
  1. Uninstall Site Server 3.0.
  2. In User Manager, click User Rights on the Policies menu.
  3. Click to select the Show Advanced User Rights check box.
  4. Select Access this computer from network in the Rights list.
  5. Click Add, double-click Everyone, and click OK twice.
  6. Reinstall Site Server 3.0.

Modification Type:MajorLast Reviewed:7/30/1999
Keywords:kbprb KB189747