ACC: Imported Time Values Filtered Incorrectly (189116)
The information in this article applies to:
- Microsoft Access 2.0
- Microsoft Access for Windows 95 7.0
- Microsoft Access 97
This article was previously published under Q189116 Moderate: Requires basic macro, coding, and interoperability skills.
SYMPTOMS
When you import a text file that contains time values into a Microsoft
Access database, if you filter the table on specific time values, the
filter may not return records.
CAUSE
When you import a text file into a Microsoft Access database, if that file
contains a date or a time value, a small floating point math error occurs.
When this error occurs, the number recorded for the date or time value
during the import will be slightly different from the number recorded when
you manually enter the same date or time value. When you try to filter on
the Date/Time field, Microsoft Access will see these differences as not
matching, even though the values appear to be identical.
RESOLUTION
This problem can be corrected by running an update query against the
imported table that uses the Format function to first convert the Date/Time
field value to a string, and then use the CVDate function to convert to a
date or time data type. If for example, the Date/Time field is named
MyDate, the update query would appear as follows:
Field: MyDate
Update: CVDate(Format(MyDate, "hh:nn:ss am/pm"))
STATUS
Microsoft has confirmed this to be a problem in the Microsoft products
listed at the beginning of this article.
REFERENCES
For more information about update queries, search the Help Index for
"queries, action queries" and follow the link for Update Queries.
For more information about filtering a table by using filter by form,
search the Help Index for "Filter By Form, creating."
Modification Type: | Major | Last Reviewed: | 5/9/2003 |
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Keywords: | kbbug kbnofix KB189116 |
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