Serial Mouse Stops Working After Changing COM Port Resources (188572)



The information in this article applies to:

  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98
  • Microsoft Windows 95

This article was previously published under Q188572
If this article does not describe your hardware-related issue, please see the following Microsoft Web site to view more articles about hardware:

SYMPTOMS

After you change the resources for a COM port to which a serial mouse is connected, the mouse may stop working.

You may also see an exclamation point in a yellow circle in Device Manager with the following message when you view the properties for the mouse:
This device is either not present, not working properly, or does not have all the drivers installed. (Code 24).

CAUSE

This behavior can occur if you change the resources for a COM port to which a serial mouse is connected to non-standard settings.

The standard resource settings for COM ports are:
   I/O Address   IRQ
   -----------------
   03F8           4
   02F8           3
   03E8           4
   02E8           3
				

RESOLUTION

To resolve this issue, use either of the following methods:

Method 1

Remove the serial mouse and COM port in Device Manager, and then restart the computer. To do so, follow these steps:
  1. Click Start, point to Settings, click Control Panel, and then double- click System.
  2. Click the Device Manager tab.
  3. Click the serial mouse, and then click Remove.
  4. Double-click the Ports (COM & LPT) branch to expand it.
  5. Click the COM port to which the mouse is connected, and then click Remove.
  6. Click OK.
  7. After the COM port is detected again, restart the computer.

Method 2

You can resolve this issue by setting the COM port back to its original resource settings.

STATUS

Microsoft has confirmed this to be a problem in the Microsoft products listed at the beginning of this article.

Modification Type:MajorLast Reviewed:8/8/2006
Keywords:kbenv kbprb KB188572