Not All ODBC Logging Posts Logged in Database (186792)
The information in this article applies to:
- Microsoft Commercial Internet System 2.0
This article was previously published under Q186792 SYMPTOMS
When you are performing ODBC logging into an Access database, you may
notice that all posts are not logged.
For example, the first session (poststress.pl) logs the first 455 of 500
total posts. The second session (poststress2.pl) logs the first 167 of 500
total posts.
Both sessions show that logging terminates after about 32 seconds (judging
by the LogTime log field). The only difference between the scripts is that
poststress2.pl has some arbitrary print statements to the console to slow
down its execution. The highest processing time recorded in the logs for
the first session is 32,179, and the second session is 32,726; both are
just below the range of an integer.
CAUSE
This may be caused by the ProcessingTime field being set to hold int type
values. Access dumps a log entry that has invalid data because of the way
ProcessingTime is calculated, causing a value larger than 32,768 to be
posted to a field allocated to only hold an integer value.
WORKAROUND
To work around this problem, use a long integer type for ProcessingTime.
You may also want to use long integers for BytesRecvd and BytesSent,
because these will often be larger than an int when dealing with file
attachments.
Modification Type: | Major | Last Reviewed: | 3/4/2002 |
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Keywords: | kbprb KB186792 |
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