NetWare Print Queues and Printers Go Offline (186322)
The information in this article applies to:
- Microsoft Windows 95
- Microsoft Windows 95 OEM Service Release 2.1
- Microsoft Windows 95 OEM Service Release 2.5
- Microsoft Windows 98
- Microsoft Windows 98 Second Edition
This article was previously published under Q186322 SYMPTOMS
When you try to print to a printer or a print queue that is configured to
use the Microsoft Client for NetWare Networks and the Microsoft
IPX/SPX-Compatible protocol, you may receive the following error message:
There was an error writing to <\\servername\sharename> for printer
<printername>.
The network printer is no longer available. Contact your
system administrator, or try using a different printer.
This printer will be set to work offline.
To save your print job in the local printer queue, click OK.
CAUSE
This issue can occur because the Microsoft Client for NetWare Networks
working with the Microsoft IPX/SPX-Compatible protocol uses an old NCP
single-byte-enabled function call to obtain connection information for the
printer.
If the connection number is greater than 255 (FF hexadecimal), the
information is requested against an incorrect connection number. For
example, the request is for connection number 8 for a connection number
value of 264 (108 hexadecimal). If the requested connection is not logged
in, the printer is set offline.
RESOLUTION
To work around this problem, use the Novell NetWare Client 32 update for
Windows 95 available from Novell.
This issue is resolved by the following updated file for Windows 95 (all
versions):
NWPP32.DLL version 4.00.954 dated 05/28/98 9:54am 43,520 bytes
STATUS
Microsoft has confirmed this to be a problem in all versions of Microsoft
Windows 95 and Microsoft Windows 98. An update to address this problem is
now available, but is not fully regression tested and should be applied
only to computers experiencing this specific problem. Unless you are
severely impacted by this specific problem, Microsoft does not recommend
implementing this update at this time. Contact Microsoft Technical Support
for additional information about the availability of this update.
MORE INFORMATION
The third-party product discussed in this article is manufactured by a
vendor independent of Microsoft; we make no warranty, implied or
otherwise, regarding this product's performance or reliability.
Modification Type: | Minor | Last Reviewed: | 9/22/2005 |
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Keywords: | kbHotfixServer kbQFE kb3rdparty kbnetwork kbprb kbprint kbQFE KB186322 |
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