Can't Use TCP/IP-based Utilities Unless Connected to Internet (184603)
The information in this article applies to:
This article was previously published under Q184603 SYMPTOMS
When you try to use a Transmission Control Protocol/Internet
Protocol-based (TCP/IP-based) utility when you are not connected to the
Internet, you may be unable to do so. For example, Personal Web Server
and Telnet may not work correctly, and other TCP/IP-based utilities may
generate error messages.
CAUSE
This issue can occur if your computer has a dynamically assigned Internet
Protocol (IP) address from your Internet service provider (ISP). The
TCP/IP stack is not loading correctly without a specified Web address.
RESOLUTION
To work around this issue, use either of the following methods:
Connect to Your ISP Before Using a TCP/IP-based Utility
Connect to your ISP before you want to use a TCP/IP-based utility
Temporarily Assign a Static IP Address to Your Computer
For information about how to temporarily assign a static IP address to
your computer, click Start, click Help, click the Index tab, type ip
addresses, click Display, and then double-click
the "To assign a private IP address for a simple network" topic.
NOTE: After you temporarily assign a static IP address to your computer
and you are no longer using a TCP/IP-based utility, you should return your
IP configuration to its original state.
STATUS
This behavior is by design.
MORE INFORMATION
This behavior is implemented to free up system resources (or system
memory) by not loading unneeded network components.
Modification Type: | Minor | Last Reviewed: | 12/16/2004 |
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Keywords: | kbenv kbnetwork kbprb KB184603 |
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