PRB: Unable to Open Registry Key DriverID Error with Advworks (184237)
The information in this article applies to:
- Microsoft Data Access Components 1.5
- Microsoft Data Access Components 2.0
- Microsoft Data Access Components 2.1 SP2
- Microsoft Data Access Components 2.5
- Microsoft Data Access Components 2.6
This article was previously published under Q184237 SYMPTOMS
When using the Advworks data source name (DSN) that installs with the
Microsoft Data Access Components (MDAC) files, the following error may
occur:
Run-time error -2147467259(80004005) General Error Unable to Open
registry key "DriverID".
CAUSE
The MDAC installation has problems, at times, correctly creating and
registering the Advworks DSN.
This problem does not seem to occur with MDAC 2.1 sp2.
RESOLUTION
Remove the Advworks DSN using the ODBC Data Source Administrator located in
Control Panel and recreate the System DSN.
Steps to Remove and Recreate the Advworks System DSN- Select the ODBC Data Source Administrator from Control Panel.
- Click the System DSN tab, select the Advworks DSN and then click Remove.
It is a good idea to check the User and File DSN tabs to see if there
are any duplicate Advworks DSNs and remove them also.
- Select the System DSN tab and click Add.
- Locate and select the Microsoft Access Driver in the Create New Data
Source Options dialog box and click Finish.
- In the Data Source Name box, type Advworks.
- Click the Select button and find the Advworks database located at
C:\Program Files\Common Files\System\MSadc\Samples\advworks.mdb. Select
the advworks.mdb and click OK.
- Click OK. You now have a new System Advworks DSN.
STATUS
Microsoft is researching this problem and will post new information in the
Microsoft Knowledge Base as it becomes available.
REFERENCES
For additional information, please see the following World Wide Web URL:
Modification Type: | Major | Last Reviewed: | 9/17/2003 |
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Keywords: | kbDatabase kbprb KB184237 |
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