Cannot Remove Small Business Client from Client Computers (184084)
The information in this article applies to:
- Microsoft BackOffice Small Business Server 4.0a
- Microsoft BackOffice Small Business Server 4.0
This article was previously published under Q184084 IMPORTANT: This article contains information about editing the registry.
Before you edit the registry, make sure you understand how to restore it
if a problem occurs. For information about how to do this, view the
"Restoring the Registry" Help topic in Regedit.exe or the "Restoring a
Registry Key" Help topic in Regedt32.exe.
SYMPTOMS
When you select the Microsoft BackOffice Small Business Server component
using the Add/Remove Programs tool in Control Panel on a client computer,
the Client Installation Wizard starts. After you click Next, you cannot
clear the Microsoft Small Business Client check box.
CAUSE
The Small Business Client component does not have an uninstall option.
RESOLUTIONWARNING: Using Registry Editor incorrectly can cause serious problems that
may require you to reinstall your operating system. Microsoft cannot
guarantee that problems resulting from the incorrect use of Registry
Editor can be solved. Use Registry Editor at your own risk.
For information about how to edit the registry, view the "Changing Keys
And Values" Help topic in Registry Editor (Regedit.exe) or the "Add and
Delete Information in the Registry" and "Edit Registry Data" Help topics
in Regedt32.exe. Note that you should back up the registry before you edit
it. If you are running Windows NT, you should also update your Emergency
Repair Disk (ERD).
Use the following steps to completely remove the Small Business Client
component:
Removing Registry Entries- Start Registry Editor (Regedt32.exe for Windows NT or Regedit.exe for
Windows 95).
- Go to the following keys:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Small Business
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\
Uninstall\Small Business
On the Registry menu, click Save Key (Windows NT) or Export Registry
File (Windows 95) to back up these registry keys to disk.
- Select the following keys again, and then click Delete on the Edit
menu:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Small Business
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\
Uninstall\Small Business
Removing Files from the Hard Disk
The files installed on the client computer vary depending on the software
selected during Setup. The following files are installed when only the
Small Business Client component is installed:
Ocsam.dll
Ocmanage.dll
Samcl4.dll
Startcli.exe
Changing the Default Home Page for Microsoft Internet Explorer
To change the default home page for Internet Explorer, follow these steps:
Internet Explorer 4.0 and 4.01:
- Start Internet Explorer.
- On the View menu, click Internet Options.
- On the General tab, click Use Default under Home Page, and then
click OK.
Internet Explorer 3.x:
- Start Internet Explorer.
- On the View menu, click Options.
- On the Start And Search Pages tab, click Use Default, and then click
OK.
After you make this change, the default Web site opens when you start
Internet Explorer (instead of the Small Business Server Web site).
STATUS
Microsoft has confirmed this to be a problem in Small Business Server
versions 4.0 and 4.0a.
Modification Type: | Major | Last Reviewed: | 2/24/2004 |
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Keywords: | kbprb kbsetup KB184084 |
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