SMS: CTRL+ALT+DEL "Gold Key" May Not Function with IBM PC (182413)



The information in this article applies to:

  • Microsoft Systems Management Server 1.2
  • Microsoft Systems Management Server 2.0

This article was previously published under Q182413

SYMPTOMS

When performing Remote Control of certain Systems Management Server Windows NT clients, the Quick Viewer CTRL + ALT + DEL "Gold Key" for system key pass through may not work properly. It has no effect on the Systems Management Server client.

CAUSE

If the Remote Control components of IBM NetFinity are loaded upon installation, it enables KeyEx and MouX (IBM's keyboard and mouse drivers) by setting keys in HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\... Start: REG_DWORD: to "0x1". It also disables the KBDCLASS and MOUCLASS (the Microsoft keyboard and mouse drivers) by setting their keys to "0x4".

WORKAROUND

To work around this problem, disable the IBM NetFinity driver (KeyEx) and then enable the Keyboard Class driver. To prevent this problem from occurring in the future, do not install the Remote Control component of NetFinity if you plan to use the Remote Control functionality of Systems Management Server.

MORE INFORMATION

This problem has been attributed to the IBM NetFinity driver (KeyEx). Certain IBM computers have the NetFinity driver preinstalled from the manufacturer.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:6/14/2005
Keywords:kbprb kbRemoteProg kbtshoot KB182413