XADM: Unable to Upgrade from Exchange Server 4.0 to 5.5 (182320)



The information in this article applies to:

  • Microsoft Exchange Server 5.5

This article was previously published under Q182320

SYMPTOMS

When you upgrade from Microsoft Exchange Server version 4.0 to Exchange Server 5.5, Setup may terminate with the following error message:
An unexpected error has returned, the error is 0xc1060107

CAUSE

This problem occurs because Setup mishandles a return code while upgrading the private information store.

WORKAROUND

To work around this problem, upgrade to Exchange Server 5.0, and then upgrade to Exchange Server 5.5.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Exchange Server version 5.5.

A supported fix is now available, but has not been fully regression-tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next service pack that contains this fix. Contact Microsoft Technical Support for more information.


MORE INFORMATION

During the upgrade process, the Setup program must upgrade the public and private information stores to a version that is compatible with Exchange Server 5.0. It is during this process that the upgrade fails.

In order to use the fix, you must copy the Server\Setup\<platform> folder from the Exchange Server 5.5 CD-ROM to a local hard drive, copy the fix to that folder, and then run Setup from there.

Modification Type:MinorLast Reviewed:9/23/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB182320