RPC May Cause System to Stop Responding during Shutdown (182288)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Workstation 4.0

This article was previously published under Q182288

SYMPTOMS

When you perform a system shutdown, the Spooler service may stop responding (hang), causing the system to stop responding and not completely shut down.

CAUSE

During a shutdown, the Spooler service will attempt to perform a clean shutdown. The Spooler service may use remote procedure calls (RPCs) to converse over the network during this clean shutdown process. When this occurs, the system may stop responding as the server is not able to listen for a reply of the RPC. The RPC deadlock occurs infrequently.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

152734 How to Obtain the Latest Windows NT 4.0 Service Pack


STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.

Modification Type:MinorLast Reviewed:9/23/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbWinNT400sp4fix KB182288