Modem Does Not Dial All Numbers in Calling Card Rule (177978)
The information in this article applies to:
This article was previously published under Q177978 SYMPTOMS
When you attempt to use a calling card rule with Dial-Up Networking,
HyperTerminal, Microsoft Fax, Phone Dialer, or any other program that uses
Windows 95 telephony, your modem may not dial all the numbers in the dial
string.
CAUSE
This behavior can occur if either of the following conditions exists:
- The buffer on your modem is too small to store all the numbers in the
calling card rule.
- The following line exists in your modem's .inf file:
HKR, Settings, DialSuffix,, ";"
The semicolon (;) between the quotation marks causes your modem not to
dial all the numbers in the calling card rule.
RESOLUTION
To resolve this behavior, follow the steps in the appropriate section
below:
The Buffer on Your Modem Is Too Small
To determine if the buffer on your modem is too small to store all the
numbers in the calling card rule, follow these steps:
- Click Start, point to Programs, and then click MS-DOS Prompt.
- At the command prompt, type the following command, and then press
ENTER:
echo atdt <dial string> > com<n>
where <n> is the number of the communications port your modem is
connected to, and <dial string> are the numbers you specified in the
calling card rule.
If your modem does not dial all the numbers in the calling card rule,
the buffer on your modem is too small. To resolve this issue, contact the
modem's manufacturer to inquire about a possible firmware update.
The .inf File Contains a "DialSuffix" Line with a Semicolon
Microsoft does not encourage or support changes to .inf files; therefore,
Microsoft Technical Support does not support the procedure in this
article. Although we have tested the following procedure and it appears to
function as described, make a backup copy of your modem's .inf file before
you proceed.
- Use any text editor (such as Notepad) to open your modem's .inf file in
the Windows\Inf folder. Please see the "More Information" section later
in this article for the .inf file your particular modem uses.
NOTE: The Inf folder is a hidden folder. To view this folder, click
Start, point to Programs, click Windows Explorer, click Options on the
View menu, click Show All Files on the View tab, and then click OK.
- Search for all instances of the following line, and remove the
semicolon only (do not remove the quotation marks):
HKR, Settings, DialSuffix,, ";"
- Save the .inf file, and then quit the text editor.
- Click Start, point to Find, and then click Files Or Folders.
- In the Named box, type drvdata.bin drvidx.bin, and then click Find Now.
- In the list of found files, right-click each file, and then click
Delete.
- Close the Find window.
- Click Start, point to Settings, and then click Control Panel.
- Double-click Modems.
- On the General tab, click your modem, and then click Remove.
- Click Add.
- If you want Windows 95 to detect your modem, click Next. If not,
click the "Don't detect my modem; I will select it from a list" check
box to select it, and then click Next.
- If you chose to have Windows 95 detect your modem, Windows 95 queries
the serial ports on your computer looking for a modem. If Windows 95
detects an incorrect modem, click Change, and then click the
appropriate manufacturer and model for your modem. Click Next, and
then skip to step 16.
- If you choose to select your modem manually, click the appropriate
manufacturer and model for your modem, and then click Next.
- Click the communications port your modem uses, and then click Next.
- Click Finish, and then click Close. The .bin files you deleted are
replaced with new versions, and the updated .inf file for your modem
is used.
Modification Type: | Major | Last Reviewed: | 12/17/2000 |
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Keywords: | kbprb KB177978 |
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