PRB: Accessing FoxPro Table in ASP Returns Error 80040e14 (175801)



The information in this article applies to:

  • Microsoft Visual InterDev 1.0
  • Microsoft ODBC Driver for Visual FoxPro (Build 6.00.8281.00) 5.0

This article was previously published under Q175801

SYMPTOMS

The following error occurs when previewing an Active Server Pages (ASP) page that contains a connection to a Visual FoxPro table:
'Microsoft OLE DB Provider for ODBC Drivers error '80040e14' [Microsoft][ODBC Visual FoxPro Driver]File '<your .dbf filename>' does not exist.
/<your web name>/<your .asp filename>, line <line number in .asp>
When you access the Visual FoxPro tables from within Visual InterDev through the Query Builder, the records return without error.

CAUSE

This error message can be caused by any of the following configuration scenarios:
  • The FoxPro database file is located on a machine other than the Internet Information Server (IIS) server. For example, your Web server with IIS is on "Server 1" and your .dbf files are on "Server 2."

    -and-

    IIS Server is configured to use NT Challenge/Response when accessing secured script files. For example, either by setting ACLS or selecting only the "NT Challenge/Response" check box in the "IIS Manager."
  • The FoxPro database file is located on a machine other than the machine running IIS.

    -and-

    IIS is configured to use the IUSR_computername account for anonymous access.

    -and-

    The script file being access is not secured and permits anonymous access.

    -and-

    The IUSR_computername is a local account and the same account/password does not exist on the remote machine (the machine that has the FoxPro database).
  • The FoxPro database file is located on a machine other than the machine running IIS.

    -and-

    IIS is configured to use Basic (Clear Text) authentication when accessing secured script files.
  • The FoxPro database files are located on the same server as the IIS.

    -and-

    You are using UNC pathing to the .dbf files.

RESOLUTION

A possible workaround for this issue is to move the FoxPro database file to the server running IIS.

If it is not possible to move the FoxPro database file locally, the following workarounds can be used.

Use Basic Authentication instead of NT Challenge response when accessing secured scripts that query FoxPro database files located on another server. If Using Basic Authentication is not an option, You can also do the following using Anonymous access for your web application.
  • Create the anonymous user account (by default, it is IUSR_machinename account) with the same password on the remote computer containing the FoxPro database file or specify DOMAIN\IUSR_computername for anonymous user account on IIS.
  • Grant access to the FoxPro database file or share for the authenticated user.
  • In Internet Information Services (MMC), in Properties, clear the Allow IIS To Control Password option. In IIS 4.0, it is called Enable Automatic Password Synchronization.

    -or-

    In MMC, right-click the Virtual directory, select Properties. On the Directory Security tab, in the Anonymous access & Authentication Control section, click Edit. In the Anonymous Access section, click Edit, and then clear the Allow IIS To Control Password option.
  • In the System DSN that points to the remote data, click Options, and then clear the Fetch data in background check box. If you are using a DSN-less connection, include BackgroundFetch=No in the connection string.

STATUS

This behavior is by design.

MORE INFORMATION

When using NT Challenge/Response with IIS, the users credentials are created at the browser. The credentials are then sent to IIS. IIS cannot forward those credentials on to another server.

The connection is attempted, but there is no username specified when connecting to the remote machine, so the connection fails.

REFERENCES

For additional information, please see the following article in the Microsoft Knowledge Base:

166029 PRB: Cannot Open File Unknown Using Access

For the latest Knowledge Base articles and other support information on Visual InterDev and Active Server Pages, see the following page on the Microsoft Technical Support site: The following related whitepaper is also available on the MSDN:

Modification Type:MajorLast Reviewed:5/2/2006
Keywords:kbDatabase kberrmsg kbprb kbSecurity KB175801