BUG: Remote COM Server Shuts Down After 6 Minutes (175020)
The information in this article applies to:
- Microsoft Win32 Software Development Kit (SDK) for Windows NT 4.0
This article was previously published under Q175020 SYMPTOMS
When a COM client on a Windows NT machine runs under an identity that
cannot be authenticated on the remote machine, a COM server started by the
client will shut down in approximately six minutes.
CAUSE
This problem is caused by a bug in the ping component of the NT OXID
resolver process (Rpcss.exe). Even though the activation is unsecure, the
ping client in the resolver process attempts secure pings. This problem
does not happen with the DCOM95 resolver process.
RESOLUTION
At present there is no way to resolve this problem except to run the client
under a user account that can be validated on the server. This could either
be a Windows NT domain account that is known on the server or a local
machine account that exists on the server (if the server is on a Windows NT
machine). In case of the latter, the ASCII user name and password of the
account on the client and the server must match exactly.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
This problem was corrected in Windows NT Service Pack 4.
Modification Type: | Major | Last Reviewed: | 10/15/2002 |
---|
Keywords: | kbAPI kbBug kbDSupport KB175020 |
---|
|