SMS: Client Setup Does Not Check for Smsrun16/32.exe (174952)
The information in this article applies to:
- Microsoft Systems Management Server 1.0
- Microsoft Systems Management Server 1.1
- Microsoft Systems Management Server 1.2
This article was previously published under Q174952 SYMPTOMS
While logging on, you may receive the following error:
SMSRUN16\32 cannot find the file smsrun16.exe or smsrun32.exe or one of
its components. Make sure the path and filename are correct and that all
required libraries are available.
CAUSE
This error message appears in situations where you have multiple
installations of an operating system on a computer, or when a computer is
upgraded from one operating system to another and the new operating system
is in a different directory than the old one.
WORKAROUND
To work around this problem, run the Upgrade.bat file to update the Systems
Management Server client setup.
STATUS
Microsoft has confirmed this to be a problem in Systems Management Server
version 1.2. This problem was corrected in the latest Microsoft Systems
Management Server 1.2 U.S. Service Pack. For information on obtaining the
service pack, query on the following word in the Microsoft Knowledge Base
(without the spaces):
MORE INFORMATION
When Systems Management Server verifies client installation, it verifies
that Smsrun16.exe or Smsrun32.exe is on the load= line of the Win.ini file.
If Systems Management Server does not find one of these executable files on
the load= line, it adds the appropriate entry. However, Systems Management
Server does not check to see that one of these executable files is actually
located in the current operating system directory specified by the
LocalWindowsPath entry of the Sms.ini file.
Modification Type: | Minor | Last Reviewed: | 6/14/2005 |
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Keywords: | kbbug kbsetup KB174952 |
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